Neje max 4 not recognised on Lighburn after using Neje 3 software

I have posted another issue earlier with my Neje Max 4 using Lighburn where the machine was engraving skewed letters and images. In that post, a user suggested that I tried the Neje 3 software to see if that issue is repeated. I installed the Neje 3 software which is I do not find to be very useful at least on a Mac. I tried to use it but it feels hopeless.

So when I returned to Lightburn, it would no longer recognise my Neje Max 4 !!!

I removed the device and tried to reinstall it but Lightburn would not find it at all. I then uninstalled Lightburn and reinstalled it and again nothing. Lightburn no longer recognizes Neje Max 4. So using the Neje 3 software messed up everything for me. I cannot use the machine anymore with Lightburn.

Overall, my experience with NEJE so far has been very bad. First, the machine does not work well and engraves everything skewed to the left (see my other issue that I posted earlier). I have spend more than a week trying to figure out what is the problem and nothing works. Second, the advice to install the Neje 3 software (a hopeless software) has completely messed up the interaction of Neje Max 4 with Lightburn.

What next? Any ideas?

This will help you